WARNING: One or more updates have been skipped due to a dependency conflict

Вот такая надпись меня ждала при очередном обновлении в mate , мой тугой англицкий язык .. даже при помощи гуглопереводчика , как то не помог , поняла что какой то конфлик зависимостей но как решать проблему…голова не давала советов)))

Хорошо есть канал на IRC  на кальке, есть там такой человечек как mavriq (кстати.. сборка CLDM , калькомате..его рук дело) , вот он кстати и помог в решении проблемы, оказалось надо в терминале:

grep -R dev-libs/libtasn1 /etc/portage  (показывает где прописан конфликтующий пакет)

и …

grep -RB5 dev-libs/libtasn1 /etc/portage ( я так поняла более полное описание кому и зачем он требуется)

Решение.. бегом в ..

/etc/portage/package.keywords.custom

удаляем запись в виде:

/etc/portage/package.keywords/custom-# required by @CLDM
/etc/portage/package.keywords/custom-# required by @custom
/etc/portage/package.keywords/custom-# required by @selected
/etc/portage/package.keywords/custom-# required by @world (argument)
/etc/portage/package.keywords/custom:=dev-libs/libtasn1-3.4-r1 ~x86
/etc/portage/package.keywords/custom-# required by net-im/pidgin-2.10.9-r1[gstreamer]

Откуда и когда.., и какой пакет потребовал туда записать оное…. не помню)) но даное действие помогло разрешить конфликты при обновлении.

может быть кому нибудь даная запись поможет ))

WARNING: One or more updates have been skipped due to a dependency conflict: 1 комментарий

  1. Уведомление: sina

Добавить комментарий